LibreOffice 3.6 breve apunte

Hace unos instantes he actualizado mi LibreOffice 3.4 a 3.6, para lo cual, desinstalé del todo el programa, o ese pensaba yo.

Al arrancarlo de nuevo, me saltó un mensaje de error que comenzaba con

«Unhandled exception invalidregistryexception»

El mensaje es bastante mas largo. Consultando por ahí, en una web dicen que para arreglar fácilmente el problema, se borre la carpeta de usuario, que no se borra al desinstalarse el programa.

Si tenemos configuraciones y mucha personalización, esto puede ser un problema. Yo antes de borrar siempre me hago una copia de seguridad de la existente. A lo mejor después del primer arranque podemos actualizar o añadir componentes a la «nueva carpeta de usuario» una vez restaurada por el nuevo LibreOffce.

En mi caso, como suelo tener casi todo por defecto o lo mas estándar posible, no me arriesgaba a perder mucho (aunque si hice la copia por si acaso). Después de esto, el primer inicio es para generar otra vez dicha carpeta, y en el segundo ya puedes usar bien el LibreOffice.

Esto me servirá de apunte por si alguna vez me pasa algo similar en las posteriores versiones.

La información la he sacado de aquí (en inglés):
http://ask.libreoffice.org/en/question/4645/libreoffice-360-always-crash-after-install-why/

Y la información de dónde se encuentra la carpeta de usuario (ubicación) de este documento (referenciado desde el otro):
https://wiki.documentfoundation.org/UserProfile/es

Nota de opinión personal

No sé si está contemplada en la instalación de los LibreOffice, quizás alguien me pueda sacar de dudas en los comentarios. Se por ejemplo que el VideoLAN VLC, cuando sacan una nueva versión, para evitarse problemas desinstalan la anterior, que creo que es una buena opción, aunque también tiene posibilidad de limpiar el cache y demás del VLC (cosa que recomiendan).

Yo casi por norma suelo hacer lo mismo con muchos programas (a no ser que tengan una personalización importante. Pues al final sino las actualizaciones o puestas encima de lo anterior, acaban ocupando mas que las versiones «limpias», por componentes que han dejado de utilizarse o similares.

En cierto sentido, todos los programas deberían tener un «instalador» que dirigiera de verdad al usuario, y no con el típico «siguiente, siguiente, finalizar», sino que informase al usuario de que tiene una versión anterior, que si quiere actualizarlo convenientemente, conservando sus ficheros de personalización, y desactivando aquellos que ya no sean de uso o avisándole convenientemente, o bien que si quiere desinstalar lo antiguo y poner lo nuevo desde cero, borrando hasta la personalización que tenga (o dando opción a que se haga una copia de seguridad antes de proceder).

Lo que viene siendo una instalación «decente», creo que por comodidad muchos desarrolladores ahora prefieren «que te lo den todo hecho» y que el usuario «elija lo menos posible», no sea que la cague. No creo que sea una buena idea que sea el instalador el que mande y el usuario que no le den a elegir.  Se pueden hacer las cosas simples teniendo un poco de cabeza, y al mismo tiempo haciendo que se aprenda un poco mas del manejo del ordenador.

2 comentarios

  1. Hola Ignacio, cuando intento dejar un comentario en tu post http://www.avalonsoftware.org/vagoblog/?p=104 me sale un mensaje de error, Sorry, comments are closed for this item. (en ingles !!!),
    pero si no se pueden escribir comentarios porque deja escribirlo, lo logico seria que mostrara desde un principio que los comentarios estan cerrados y no me permitiera escribir el comentario

  2. El plugin que usaba para ello, parece que con las ultimas versiones de WordPress no funciona. Lo he desactivado, ahora se puede volver a escribir en textos de hace varios años. 🙂 Gracias por el aviso.

ATENCIÓN: Puedes opinar sin meter Correo electrónico o Web.


Deja un comentario

Tu dirección de correo electrónico no será publicada.

*

code

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.